# CONTENTS

<table>
<thead>
<tr>
<th>Chapter 1</th>
<th>Introduction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report creation in DPA</td>
<td>10</td>
</tr>
<tr>
<td>Data sources and operators</td>
<td>10</td>
</tr>
<tr>
<td>Useful operators and data sources</td>
<td>11</td>
</tr>
<tr>
<td>Examples of Search Replace regular expressions</td>
<td>12</td>
</tr>
<tr>
<td>Smart Groups</td>
<td>12</td>
</tr>
<tr>
<td>Date and timestamps in DPA</td>
<td>12</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 2</th>
<th>Custom report examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a custom report from an existing system report template</td>
<td>14</td>
</tr>
<tr>
<td>Adding reports to menus</td>
<td>15</td>
</tr>
<tr>
<td>Creating a simple custom report from scratch</td>
<td>16</td>
</tr>
<tr>
<td>Creating a custom report with conditions set on a data source</td>
<td>17</td>
</tr>
<tr>
<td>Adding Summarise operator to a custom report</td>
<td>19</td>
</tr>
<tr>
<td>Adding Extended Job Rollup operator to a custom report</td>
<td>21</td>
</tr>
<tr>
<td>Adding Translation operator to a custom report</td>
<td>23</td>
</tr>
<tr>
<td>Creating a custom report using an aggregate data source</td>
<td>24</td>
</tr>
<tr>
<td>Creating a custom report using Concatenate operator</td>
<td>26</td>
</tr>
<tr>
<td>Creating a custom report using a Database Query data source</td>
<td>28</td>
</tr>
<tr>
<td>Creating a custom report using multiple data sources and operators</td>
<td>30</td>
</tr>
</tbody>
</table>
As part of an effort to improve its product lines, EMC periodically releases revisions of its software and hardware. Therefore, some functions described in this document might not be supported by all versions of the software or hardware currently in use. The product release notes provide the most up-to-date information on product features.

Contact your EMC technical support professional if a product does not function properly or does not function as described in this document.

**Note**

This document was accurate at publication time. Go to EMC Online Support (https://support.emc.com) to ensure that you are using the latest version of this document.

**Purpose**

The purpose of this document is to provide information on building Data Protection Advisor (DPA) custom reports. This document provides examples of creating basic custom reports to more complex custom reports.

**Audience**

This document is intended for users of DPA. Readers of this document are expected to have administrator knowledge of DPA and of the backup and recovery environment on which DPA monitors and reports.

**Revision history**

The following table presents the revision history of this document.

<table>
<thead>
<tr>
<th>Revision</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>March 31, 2014</td>
<td>First release of this document for EMC Data Protection Advisor 6.2 and Minor Releases.</td>
</tr>
<tr>
<td>02</td>
<td>March 25, 2016</td>
<td>Updates to Useful operators and data sources on page 11</td>
</tr>
</tbody>
</table>

**Related documentation**

The DPA documentation set includes the following publications:

- *EMC Data Protection Advisor Custom Reporting Guide*
- *EMC Data Protection Advisor Data Collection Reference Guide*
- *EMC Data Protection Advisor Installation and Administration Guide*
- *EMC Data Protection Advisor Migrator Technical Notes*
- *EMC Data Protection Advisor online help system*
- *EMC Data Protection Advisor Product Guide*
- *EMC Data Protection Advisor Release Notes*
- *EMC Data Protection Advisor Report Reference Guide*
- *EMC Programmers’ Guide to Using DPA REST API*
Special notice conventions used in this document
EMC uses the following conventions for special notices:

**NOTICE**
Addresses practices not related to personal injury.

**Note**
Presents information that is important, but not hazard-related.
Typographical conventions
EMC uses the following type style conventions in this document:

**Bold**
Use for names of interface elements, such as names of windows, dialog boxes, buttons, fields, tab names, key names, and menu paths (what the user specifically selects or clicks)

*Italic*
Use for full titles of publications referenced in text

**Monospace**
Use for:
- System code
- System output, such as an error message or script
- Pathnames, file names, prompts, and syntax
- Commands and options

*Monospace italic*
Use for variables

*Monospace bold*
Use for user input

[]
Square brackets enclose optional values

|
Vertical bar indicates alternate selections - the bar means “or”

{}
Braces enclose content that the user must specify, such as x or y or z

...
Ellipses indicate non-essential information omitted from the example

---

Where to get help
EMC support, product, and licensing information can be obtained as follows:

**Product information**
For documentation, release notes, software updates, or information about EMC products, go to EMC Online Support at [https://support.emc.com](https://support.emc.com).

**Technical support**
Go to EMC Online Support and click Service Center. You will see several options for contacting EMC Technical Support. Note that to open a service request, you must have a valid support agreement. Contact your EMC sales representative for details about obtaining a valid support agreement or with questions about your account.

**Online communities**
Visit EMC Community Network at [https://community.emc.com](https://community.emc.com) for peer contacts, conversations, and content on product support and solutions. Interactively engage online with customers, partners, and certified professionals for all EMC products.

**Your comments**
Your suggestions will help us continue to improve the accuracy, organization, and overall quality of the user publications. Send your opinions of this document to [DPAD.Doc.Feedback@emc.com](mailto:DPAD.Doc.Feedback@emc.com)
CHAPTER 1
Introduction

This chapter contains the following topics:

- Report creation in DPA
- Data sources and operators
- Useful operators and data sources
- Smart Groups
- Date and timestamps in DPA
Report creation in DPA

DPA reports are made up of a number of data sources and operators linked together to form the report design.

A data source can be thought of as a visual representation of a SQL query. It returns data from a table in the database. Each data source has a descriptive name and resides in a category. The category determines what kind of data the data source returns. For example, the Backup All Jobs data source returns information regarding backup jobs and resides in the Backup category. The Num Clients data source returns information about the number of backup clients and also resides in the Backup category. Both of these data sources return data pertaining to general backup job data. The Filesystem Capacity data source returns information on the capacity of a file system. It is in the Filesystem category.

Some data sources return data only for a specific backup application. These are in the specific categories. For example, the EMC Avamar category contains data sources that only return data when run against an EMC Avamar object.

It is useful to get a report to return data from a table with a data source. The ability to do "things" with that data is even more useful. By this we mean, leverage and combine the data to return even more meaningful information. This is where operators come into play. An operator gives you the ability to perform an operation on the data returned by a data source. The operation could be a simple count of the number of rows returned by the data source, such as with the Count operator. The operation could be more complex, like looking for a value in a field and replacing it with another value, for which you would use the Search and Replace operator.

Operators, just like data sources, reside in Categories. An operator’s category determines what kind of overall operation it does. If you know the name of the operator, you can use that name to look for it. If not, search for an operator category instead. For example, if you want to find the Count operator, try looking under the Math category, as a count is a mathematical operation. If you want to multiply the value of a field with a number, try looking for an operator called Multiply, again in the Math category, because multiplication is a mathematical operation. Would you like to group rows from a data source together by a certain field? That would be aggregation, so try looking under the Aggregate category.

Data sources and operators

We recommend efficiency with data sources and operators. The fewer operators you use, the better.

If you have no idea where to start with a data source, the DPA web console itself includes a wealth of information about source categories and the data sources included therein. Go to Reports > Report Templates > Custom Report Templates > Create Custom Template and click Add Data Source. By reviewing the source categories and data sources, you gain an understanding of the way DPA categorizes data for reporting.

A distinction to consider when choosing a data source is whether you would like aggregated and summary information, or if you would like detailed information in your report. Data sources that include words like summary, aggregation, num, total, and statistics are ones that provide aggregated or summary information. Data sources that include words like details, config, or status provide detailed information.

For example, as a custom report writing best practice, if you want a report that shows the top 10 longest running jobs over the last week, use only one data source, the Backup Statistics data source, and no operators. If you choose an optimal data source at the start
of building the custom report, you save yourself the step later of setting conditions to eliminate unwanted data. It also saves computing time and power, so you retrieve the data sooner.

An example of this would be Backup Statistics data source versus the Backup Job Details data source. This is the equivalent of the performance impact of running a report that returns all the data within the reporting window—for example by using a Backup Job Details data source—versus one that just returns the information required to get the desired output—using Backup Statistics data source instead. Using the Backup Statistics data source creates a report that is easier to understand for anyone using or modifying it because it simplifies the report design. It is also quicker to run when either the data set or the time period over which the report is run becomes large.

**Useful operators and data sources**

This section contains frequently used data sources and operators and the categories in which they can be found. The DPA online help provides detailed explanations of all the operators and data sources in DPA.

To view a data source and description, click **Select Data Source › View Data Source Description**. The following are frequently used and very useful data sources:

- **Database Query**—Returns the output of a SELECT statement against a database (External Category). Creating a custom report using a Database Query data source on page 28 provides an example of how to build a report with this data source.
- **Read CSV**—Reads data from a comma separated values file, and turns it into a data set (External Category).

To view an operator description, click **Select Operator › View Operator Description**. The following are frequently used operators:

- **Merge**—Merges data from two different data sources based on the same key fields (Misc Category).
- **Count**—Counts the number of elements in a data set (Math Category).
- **Group By**—Applies a grouping operation to fields in a data set (Aggregate Category). Creating a custom report using multiple data sources and operators on page 30 provides an example of how to use these operators.
- **Extended Job Rollup**—Rolls up backup jobs to a summary based on the specified fields (Backup Category). Adding Extended Job Rollup operator to a custom report on page 21 provides an example of how to use this operator.
- **Search and Replace**—Uses regular expressions to look at values in a field and alter their contents as per the replacement string. (Misc Category) This concept is probably familiar to UNIX users. This is not a DPA invention; DPA merely use it as a Java function. DPA uses Java’s implementation of regular expressions. Examples of Search Replace regular expressions on page 12 provides information.
- **Translation**—Uses a flat file containing key pair values to map the value of one field in a data set to a different value (Misc Category). Adding Translation operator to a custom report on page 23 provides an example of how to use this operator.
- **Concatenate**—Concatenates two fields with string values to a single output (Misc Category). Creating a custom report using Concatenate operator on page 26 provides an example of how to use this operator.
- **Set Value**—Gives you the ability to set a value of a field based upon a condition (Misc Category).
Examples of Search Replace regular expressions

- $1 up to 1st underscore $2 is between 1st & 2nd underscore
  - Replace String :$1$2,
  - Search String :^\(.*?_*.*\)_.*\^\(|.*\).*

- For first three alphanumeric characters:
  - Replace String : $1
  - Search String : (^[\w]{0,3})(.*)

- Append domain name static suffix:
  - Replace String : $0.fully.qualified.name
  - Search String: (.*)[^\1]

- $1 is to first full stop
  - Replace String : $1
  - Search String : ([^\s]*\1)*

- change Tue3 to Tu3 :
  - Replace String: $1$3
  - Search String: (.)(2)(\1)

- take string until end of a 12 digit date:
  - Replace String: $1
  - Search String : (.*[0-9]{12})(.*)

- Based upon one set of 12 numbers in a row (the date format)

Smart Groups

If you find yourself reporting repeatedly on the same groups, create Smart Groups to enable reporting by desired groups. Ideal groups are business-centric and applicable. For example, if you create Smart Groups by business unit, cost centre, or geographic distribution with other server and client information, you can then optimize the groups and other DPA system template or custom reports to gather more data. You do not have to re-create the same custom reports repeatedly.

The DPA online help system and DPA Installation and Administration Guide provide information on creating Smart Groups.

Date and timestamps in DPA

All dates and timestamps are stored in UNIX format (that is, epoch format) within the DPA database. Because date and time stamps are in UNIX time, they are just integers and you can use mathematical operators on them. However, you should be aware of the ‘cast’ of the resultant field.

There are free downloads available to convert from UNIX time.
CHAPTER 2

Custom report examples

This chapter contains the following topics:

- Create a custom report from an existing system report template ...................... 14
- Adding reports to menus ...................................................................................... 15
- Creating a simple custom report from scratch .................................................... 16
- Creating a custom report with conditions set on a data source ......................... 17
- Adding Summarise operator to a custom report .................................................. 19
- Adding Extended Job Rollup operator to a custom report ................................. 21
- Adding Translation operator to a custom report ............................................... 23
- Creating a custom report using an aggregate data source ............................... 24
- Creating a custom report using Concatenate operator ..................................... 26
- Creating a custom report using a Database Query data source ....................... 28
- Creating a custom report using multiple data sources and operators ............... 30
Create a custom report from an existing system report template

Before starting to create a custom report from scratch, the best practice is to check for an existing system template report that fits your needs and if required, modify to certain specifications.

Custom report objective: You would like a report that provides information on the number of clients in your environment by server and formatted in a column chart. DPA calls its client a backup client. So you should look for a report with the words backup client in either the report title or description.

Procedure

1. In the DPA web console, go to Reports > Report Templates > System Report Templates.
2. Click on the Filter icon, and type Backup Client Count in the empty field above System Template Name. You can type a few of the words you believe might be in the report name.
   
   The field autopopulates with all System Templates that contain the words you type.
   
   Backup Client Count by OS Type is one of the results. You can modify this report to give results by server instead of by OS type.
3. Select Backup Client Count by OS Type and click Save As Custom Template.
4. In the Create Custom Template window, type a name in the Name field. For example, "<your initials> Backup Client Count by Server." (Optional) Type a description in the Description field.
5. Click on the Summarise operator and expand the Parameters properties.
   
   This report by default returns information by OS type. You would like information by server. So you need to modify the Summarise operator.
6. Click Edit to modify the Parameters properties.
7. In the dropdown for Summary field, select Server. Then click OK.

Note

You can press the S key while in the dropdown, and all the field names beginning with S will come to the top of the list. This is a helpful shortcut rather than scrolling through all the fields to find the field name you are looking for.

8. Go to the Fields tab and select the Include All checkbox.
   
   You do this because you would like information on servers to be included as well as Count.
   
   At this point the report includes all the parameters to return the information you require. The report format may need modification.
9. Go to the Preview tab.
10. Click Chart Format, and in the Report tab, change the title to Backup Client Count By Server, and click Ok and Save.
    
    This is the title that displays on the report.
    
    In order to run the report, you must set a scope and time period for the report.
11. Click Select Scope, and, because you'd like information on servers, select Configuration > Servers. Click Ok.
12. Click **Select Time Period** and from the list, select **Now**. Then click **Select** and **OK**.

This report uses a Point In Time data source which means that it will return the current configuration. So even if a Time period Last Week was set, it would still return the current configuration.

**Adding reports to menus**

When you create a report, you should ensure that the report is available in your default Navigator menu and that you have rights to your Navigator Menu according to your role in DPA. This is so that you can run any custom report that you create directly on objects in the Run Reports section instead of having to go to the Report Editor.

**Procedure**

1. Ensure that your newly created custom report is available in your Report Menu. Go to Reports > Report Menus.
2. Verify that you have the Navigator Menu selected and click **Save As**.
3. In the **Menu Name** field, type a name for your Navigator menu and click **OK**.
4. Add a new folder to your newly created Navigator menu:
   a. Select your newly created Navigator menu.
   b. Click on the New Folder icon in the upper-most left of the pane.
   c. Type a name in the **Folder Name** field.
   d. Click the Add New Menu Item icon in the upper left of the pane.
      You can add a menu item to any folder by selecting the folder first, then clicking on the New Menu item.
5. Add your newly created custom report to the your newly created Navigator menu:
   a. In the **Menu Item Name** field, type `<your initials> Backup Client Count by Server`.
   b. In the **Menu Item** field, ensure that the **Report** radio button is selected and click **Select** to browse and select your custom report.
   c. From the **Select Report Template** dialog box go to the **Custom Report Templates** tab to select your newly created custom report and click **Select**.
   d. Click **OK** to save your updated version of the Navigator Menu.
6. Ensure that you have rights to your Navigator Menu according to your role in DPA. Go to **Admin > Users & Security > Manage Users**.
7. Select **Administrator** and click **Edit**.
8. In the **View User Properties** window, click the **Report Preferences** tab.
10. Click **OK** and then click **Close**.
Creating a simple custom report from scratch

Custom report objective: Create a simple custom report that displays a list of All Jobs for a time period.

Procedure

1. In the DPA web console, go to Reports > Report Templates > Custom Report Templates and click Create Custom Template.
2. In the Name field, type a name for the custom report.
   For example, <your initials> Job Details.
3. Add the data source:
   - Click Add Data Source and select Backup > Backup Job Details data source.
   - Alternatively, search for the data source similarly to the way you search for reports:
     a. Click Add Data Source and then click the Filter icon on the top right of the Select Data Source window.
     b. Select Show Filter from the menu options and type Backup Job Details in the field above the data source names.
     c. Select Backup Job Details from the list and click Select Source.
   - Alternatively search data sources by field name. Type the field name in the field above the Fields section. A list of all data sources with that field name present appear. Select the desired data source and click Select Source.

Because you want a list of jobs, you look for a data source that provides details. If you don't immediately see the data source that makes sense, scan the list of data sources and the fields contained therein. You can get a sense of the output and whether the data source contains the type of detail level you want.

4. Select the data source, go to the Time Period section, click Edit and ensure that the Interval Type is set to No Interval. If not, select No Interval from the Interval Type dropdown and click OK.
5. Click Add Connection to connect the data source to the Report object.
   Select the Report Object to display a list of all the fields that the report will now return once it is run.
   At this point the report includes all the parameters to return the information you'd like.
6. [Optional] Click Validation Errors and then click the Validation Errors link in the Validation Status at the bottom left of the Report Editor window to bring up any issues that need to be fixed before the report can be run.
   Validation Errors are mistakes in the report design that may cause the report to not return the correct results or may cause the report not to run at all.
   If the Validation Status at the bottom left of the Report Editor window shows Validation Errors, then the report format may need modification. If there is a green tick next to validation Status then the report design is correct and it can be run.
7. Go to the Preview tab.
8. Leave the default report format as Table.
   Table is the desired format for this report.
9. Click **Table Format**, and in the **Title** field, type a report title to display, and then click **OK**.

If you do not specify a report title, by default the report name displays as the report title.

10. Click **Save** to save the report.

11. Select the scope for the report. Go to **Select Scope > Configuration > Servers** [backup servers in your environment on which you’d like to run the report].

12. Select the time period for the report. Go to Select Time Period, select **Last Hour**, and then click **Select and OK**.

This report uses a Period data source with No Interval, which means it returns all of the backup jobs that started in the time period (in this example Last Hour) specified.

13. Carry out the steps in Adding reports to menus on page 15.

---

**Creating a custom report with conditions set on a data source**

Custom report objective: You would like to create a custom report that lists all Full backup jobs ordered by size. Customize the data sources and operators on your report of All Jobs for a time period.

**Procedure**

1. In the DPA web console, go to **Reports > Report Templates > Custom Report Templates**.

2. Make a copy of your backup all jobs report:
   a. Select your `<your initials> Job Details` report.
   b. Click **Save As**.
   c. In the **Name** field, type a descriptive name. For example, `<your initials> Full Level Jobs`

   You want to return all the full job types.

3. Select the **Backup Job Details** data source and edit the **Label** field under Properties to **Backup Job Details - Full Jobs**

4. Customize the Backup Job Details data source:
   a. Go to the **Fields** tab and clear the **Include All** option.
   b. Check the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level</td>
<td>Level of the Job backed up: Full, Incr, User, Manual, Cumulative Incr, Differential Incr, 1-9</td>
</tr>
<tr>
<td>Status</td>
<td>Status of the Job backed up: Success, Failed, Missed</td>
</tr>
<tr>
<td>Size</td>
<td>Amount of data backed up (in MB)</td>
</tr>
<tr>
<td>Start Time</td>
<td>Time the Job started writing</td>
</tr>
<tr>
<td>End Time</td>
<td>Time the Job completed</td>
</tr>
</tbody>
</table>

These fields provide the basic information. The *EMC Data Protection Advisor Report Reference Guide* provides more information on report fields.
5. Customize the report with a condition:
   
a. Expand the **Conditions** tab.

b. Click **Edit Condition**.

c. Click **Select Field** and then select **Level** and click **OK**.
   
   For example:

   ![Select Field Example]

   d. Click **Select Operator** and then select **Equal to**.
   
   For example:

   ![Select Operator Example]

   e. Click **Select Value** and then select the **Static value** radio button and type **Full** in the Value field.
   
   For example:

   ![Select Value Example]
f. Click OK.
   At this point the condition is set to return just jobs where the level is equal to full.

g. Click OK.

6. Customize the order of the fields for the report.
   a. Expand the Advanced tab.
   b. Select Order Flag and select Size from the Order field drop-down menu.
   c. Select Descending or Ascending from the Order Policy drop-down menu, depending on your requirement.

   At this point the report includes all the parameters to return the information you’d like. The report format may need modification.

7. Click the Preview tab.

8. Select the scope for the report. Go to Select Scope > Configuration > Servers > [backup servers in your environment on which you’d like to run the report].

9. Select the time period for the report. Go to Select Time Period, select Last Hour, and then click Select and OK.

10. Verify that the custom report meets your requirements.

11. If the report meets your needs and you want to keep it, add the report to your Navigator menu.

   Adding reports to menus on page 15 provides information.

Adding Summarise operator to a custom report

Custom report objective: You would like to create a custom report that returns the count of the number of each full job run on a Backup Server. Add the Summarise operator to your customized all jobs report to get a count of the number of runs for each full backup job within the reporting window.

Procedure

1. In the DPA web console, go to Reports > Report Templates > Custom Report Templates.

2. Make a copy of your full level jobs report:
   a. Select your <your initials> Full Level Jobs report.
   b. Click Save As.
   c. In the Name field, type a descriptive name. For example, <your initials> Job Summary.

3. Delete the connection between the Backup Job Details data source and the Report object.
   You need to add the Summarise operator between the data source and Report object.

4. Move the Report object down to create some space.

5. Add the Summarise operator. Click Add Operator > Aggregate > Summarise > Select Operator.

6. Click Add Connection and connect Backup Job Details to Summarise, and connect Summarise to Report.

7. Check for validation errors by ticking the tick mark at the bottom-left of the Report Editor window.
Note the Validation Status shows errors. Click on Validation Errors to get details of the issues with the current report design. Errors are broken down into Global Errors, which are those that affect the whole report, and Operator-based errors. In this case the errors are associated with the Summarise operator. This is because we have not set any parameters on our operator or set any fields to be displayed by the final report. The following illustrates validation errors:

8. Customize the parameters of the operator:
   a. Select the **Summarise** operator.
   b. Expand the **Parameters** properties and click **Edit**.
   c. Select **Summary field > Job**.
   d. In **Output field**, type **Runs**.
   e. Click **OK**.
      
      For example:

Now the report returns the number of full job count entries for the backup jobs.

9. Expand **Fields** and select **Include All**.

   Include All ensures that data for all the possible fields in the report is displayed.

10. Report design should look like the one below:
    
    For example:
'Note that the validation Status is now green. This is because the errors associated with the report have been fixed in steps 8 and 9 above.

11. Click **Save**.

12. Click the **Preview** tab.

13. Select the scope for the report. Go to **Select Scope** > **Configuration** > **Servers** > [backup servers in your environment on which you’d like to run the report].

14. Select the time period for the report. Go to **Select Time Period**, select **Last Hour**, and then click **Select** and **OK**.

15. Verify that the custom report meets your requirements.

16. Add the report to your Navigator menu.

---

**Adding reports to menus on page 15** provides information.

---

**Adding Extended Job Rollup operator to a custom report**

Custom report objective: You would like to create a custom report that shows a summary of full backup job details grouped by Server, Group, Client, and backup job. Add the Extended Job Rollup operator to your Full Level Jobs report to get a summary of backup job information based on specified fields.

**Procedure**

1. In the DPA web console, go to **Reports** > **Report Templates** > **Custom Report Templates**.

2. Make a copy of your Full Level Jobs report:
   a. Select your `<your initials>` **Full Level Jobs** report.
   b. Click **Save As**.
   c. In the **Name** field, type a descriptive name. For example, `<your initials> Extended Job Rollup`

3. Select the Summarise operator and replace it:
   a. Click on the link icon on the top-right corner of the Summarise operator.

      **The Select Operator** window opens.

   b. Choose one of the following options:
- Go to Backup > Extended Job Rollup and select operator.
- Click on the Filter icon on the top-right of the window and search for the operator by name.

4. Customize the parameters of the operator:
   a. Select the Extended Job Rollup operator.
   b. Expand the Parameters properties and click Edit.
   c. In the Group By 1 field, select Server from the drop-down.
   d. In the Group By 2 field, select Group from the drop-down.
   e. In the Group By 3 field, select Client from the drop-down.
   f. In the Group By 4 field, select Job from the drop-down.
      If you choose these groups in this order, DPA returns one row per unique server, group, client, and job.
   g. In the Interval, type 0.
      This means that you do not want the data broken into intervals.
   h. Click OK to close the Edit Parameters window.

For example:

5. Click on Fields to expand the fields, and select Include All.
6. Check for validation errors by ticking the tick mark at the bottom-left of the Report Editor window.
7. Click the Preview tab.
8. Select the scope for the report. Go to Select Scope > Configuration > Servers > [backup servers in your environment on which you’d like to run the report].
9. Select the time period for the report. Go to Select Time Period, select Last Hour, and then click Select and OK.
10. Verify that the custom report meets your requirements.
    Note that the report returns one row per combination of key fields, per your specifications.
11. Add the report to your Navigator menu.
    Adding reports to menus on page 15 provides information.

Adding Translation operator to a custom report

Custom report objective: Create a custom report that displays a list of NetBackup failed jobs with error descriptions.

Before you begin

- You must have access to the NetBackup error codes and descriptions.
- Create a file that contains two columns: error code and error description. This procedure uses a CSV file.
- Save the file on a web server and have the web server mapping/location available.

The translation operator allows you to use a piece of existing data to match to some other external data, and add a new field with that information. For this report, we don't have the NetBackup error descriptions with the backup job, only the code. So we use the translation operator to bring in the description from an external source.

Procedure

1. In the DPA web console, go to Reports > Report Templates > Custom Report Templates and click Create Custom Template.
2. In the Name field, type a name for the custom report.
   For example, <your initials> Failed Jobs With Err Desc.
3. Click Add Data Source and select Backup > Backup Job Details data source.
4. Click Add Operator and select Misc > Translation.
5. Click Add Connection to connect the data source to the Translation operator, and connect the operator to the Report object.
6. Select the Backup Job Details data source:
   a. Expand the Fields tab.
   b. Deselect the Include All checkbox.
   c. Select the Err Code field.
7. Go to the Time Period section, click Edit and ensure that the Interval Type is set to No Interval, and click OK.
8. Expand the Condition property:
   a. Click Edit condition.
   b. Click Select Field and then select Status and click OK.
   c. Click Select Operator, and then select Equal to.
   d. Select Static Value and then type failed.
e. Click OK.

9. Select the Translation operator:
   a. Expand the Parameters property and click Edit.
   b. In the Field Name menu, select Err Code.
   c. In the Filename field, type the web server mapping/location of the file that contains the error codes and descriptions. For example: http://location/webserver/err_codes.csv
   d. In the New Field Cast field, type String.
   e. In the New Field Name field, type Error Description.
   f. In the Separator field, type ,.
   g. Click OK to close the window.

10. Expand the Fields tab:
    a. Select Include All
    b. Deselect Sub Name, Domain Name, Backup Set Session and Proxy.

11. Go to the Preview tab.
12. Leave the default report format as Table. Table is the desired format for this report.
13. Click Table Format, and in the Title field, type a report title to display, and then click OK.
    If you do not specify a report title, by default the report name displays as the report title.
14. Click Save to save the report.
15. Select the scope for the report. Go to Select Scope > Configuration > Servers > [NetBackup backup servers in your environment on which you’d like to run the report].
16. Select the time period for the report. Go to Select Time Period, select Last Hour, and then click Select and OK.
17. Carry out the steps in Adding reports to menus on page 15.

Creating a custom report using an aggregate data source

Custom report objective: You would like to create a custom report that shows a count of the number of backup jobs per client. Add the Num Jobs data source to a custom report to get information on the number of jobs per Client that have run in a reporting window and have completed.

Procedure
1. In the DPA web console, go to Reports > Report Templates > Custom Report Templates and click Create Custom Template.
2. In the Name field, type a name for the custom report. For example <your initials> Jobs by Client
3. Click Add Data Source and select Backup > Num Jobs, then click Select Source.
5. Edit the Num Jobs Time Period properties:
   a. Select the **Num Jobs** data source.
   b. Expand the **Time Period** property and click **Edit**.
   c. In the **Interval Type** field, type select **No Interval** from the drop-down and click **OK**.

   The Period type and default settings for Period, and **No Interval** are ideal for rollup reports. **No Interval** interval means that DPA returns all data points that it finds in the reporting window.

   For example:

   ![Edit Time Window](image)

   **Point in Time** type provide latest data. This information is ideal for configuration and status reports.

6. Expand the **Group By** property and check the box for **Client** field.

   The report is grouped by backup client.

7. Go to the **Fields** tab and verify that both Client and Num Jobs fields are displayed.

8. Click the **Preview** tab.

9. Leave the default report format as **Table**.

   Table is the desired format for this report.

10. Select the scope for the report. Go to **Select Scope > Configuration > Servers** > [backup servers in your environment on which you’d like to run the report].

11. Select the time period for the report. Go to Select Time Period, select **Last Hour**, and then click **Select** and **OK**.
12. Verify that the custom report meets your requirements.
13. Add the report to your Navigator menu.

*Adding reports to menus on page 15* provides information.

## Creating a custom report using Concatenate operator

### Custom report objective:
Create a custom report that displays a Backup Client Configuration information on your Avamar host and combines the domain name and client name in a single field in the client name field.

### Procedure

1. In the DPA web console, go to **Reports > Report Templates > Custom Report Templates** and click **Create Custom Template**.
2. In the **Name** field, type a name for the custom report.
   
   For example, `<your initials> Backup Client Config Domain and Client`.
3. Click **Add Data Source** and select **Backup > Backup Client Config** data source.
4. Set the time period:
   
   a. Select **data source** and go to the **Time Period** section.
   b. Click **Edit**.
   c. Ensure that the **Type** field is set to **Point In Time**.
   d. Ensure that the **Start Time** is set to **End of Time Period**.
   e. Click **OK**.
   
   This ensures that you get only the current client configuration records.
5. Add the Add Field operator and customize the parameters:
   
   a. Click **Add Operator > Misc > Add Field** and select operator
   b. Select **Add Connection** and add the Add Fields operator to the Backup Client Config data source.
   c. Select the operator, expand **Parameters** and click **Edit**.
   d. In **Cast**, select **Text**.
   e. In **Field Label**, type **Separator**.
   f. In **Value**, type **/**.
   g. Click **OK**.
   h. Go to the **Fields** tab and select the **Include All** checkbox.
6. Add the Concatenate operator and customize the parameters:
   
   a. Click **Add Operator > Misc > Concatenate** and select operator
   b. Click **Add Connection** to connect the Add Field operator to the Concatenate operator.
   c. Expand **Parameters** and click **Edit**.
   d. In **Left Field Name**, select **Domain Name**.
   e. In **Output Field Name**, type **Domain 2**.
f. In **Right Field Name**, type *Separator*.

g. Click **OK**.

h. Go to the **Fields** tab and ensure that the **Include All** checkbox is selected.

7. Add another Concatenate operator and customize the parameters.
   a. Click **Add Operator** > Misc > **Concatenate and select operator**
   
   b. Click **Add Connection** to connect the Concatenate operator to the previous Concatenate operator.

   c. Expand **Parameters** and click **Edit**.

   d. In **Left Field Name**, select *Domain 2*.

   e. In **Output Field Name**, type *Client Name*.

   f. In **Right Field Name**, type *Client*.

   g. Click **OK**.

   h. Go to the **Fields** tab and ensure that the **Include All** checkbox is selected. Then, unselect the **Separator** and **Domain 2** fields.

8. Add the Group By operator and customize the parameters.
   a. Click **Add Operator** > Aggregate > **Group By and select operator**

   b. Click **Add Connection** to connect the Group By operator to the previous Concatenate operator.

   c. Expand **Parameters** and click **Edit**.

   d. In **Group By 1**, select *Server*.

   e. In **Group By 2**, select *Sub Name*.

   f. In **Group By 3**, select *Client Name*.

   g. Leave the default operation parameters unmodified, and leave the remaining **Group By** fields unmodified.

   h. Click **OK**.

   For example:

   ![Edit Parameters](image)

9. Click **Add Connection** to connect the Group By data source to the Report object.
At this point the report includes all the parameters to return the information you’d like. The report format may need modification.

10. Go to the **Preview** tab.
11. Select **Table** as the report format.
12. Leave the default report format as **Table**.

   Table is the desired format for this report.
13. Click **Save** to save the report.
14. Select the scope for the report. Go to **Select Scope > Configuration > Servers** [Avamar backup servers in your environment on which you’d like to run the report].
15. Select the time period for the report. Go to Select Time Period, select **Last Hour**, and then click **Select** and **OK**.
16. Carry out the steps in **Adding reports to menus on page 15**.

---

**Creating a custom report using a Database Query data source**

**Custom report objective:** You would like to create a custom report that shows all clients on London mail servers. Run a report using an external database to access data on London mail servers that is not stored within the DPA server.

The Database Query data source can connect to and return data from IBM DB2, Microsoft SQL Server, MySQL, Oracle, PostgreSQL, Sybase SQL Server, if configured correctly. Step 5 below provides an example. The DPA online help provides information about parameters.

**Procedure**

1. In the DPA web console, go to **Reports > Report Templates > Custom Report Templates** and click **Create Custom Template**.
2. In the **Name** field, type a descriptive name. For example, `<your initials> London Mail Servers`.
3. Click **Add Data Source** and select **External > Database Query**, then click **Select Source**.
5. Modify the parameters of the Database Query data source:
   a. Select the **Database Query** data source.
   b. Expand the **Parameters** property and click **Edit**.
   c. In the **Type** field, select the database you want to query from the drop-down.
      For example, `postgresql`.
   d. In the **Server** field, type the host on which the database resides.
      For example, `dpa6demo`.
   e. In the **Port** field, type the port of the database listener.
      For example, for PostgreSQL, type `9003`.
   f. In the **Database** field, type the name of the database.
      For example, `samplecmdb`.
   g. In the **User** and **Password** fields, type the user and password of the user to access the database.
For example, dbuser

h. In the Query field, type the SELECT statement to run against the database.

For example, 
```
select client from appdata where application='London_Mail_Servers';
```

i. In the Key field, type list of column names that identify a unique record of the rows returned.

For example, Client

j. Click OK.

For example:

![Edit Parameters](image)

The DPA online help provides information about parameters.

6. Expand the Fields property and select Include All.

7. Click the Preview tab.

8. Leave the default report format as Table.

Table is the desired format for this report.

9. Select the scope for the report. Go to Select Scope > Configuration > Servers > [backup servers in your environment on which you’d like to run the report].

10. Select the time period for the report. Go to Select Time Period.

11. Add the report to your Navigator menu.

Adding reports to menus on page 15 provides information.
Creating a custom report using multiple data sources and operators

Custom report objective: You would like to create a custom report that returns counts of specific error types. Run a report using multiple data sources and operators to get a count of specific types of errors occurred.

Procedure

1. In the DPA web console, go to Reports > Report Templates > Custom Report Templates and click Create Custom Template.
2. In the Name field, type a descriptive name. For example, <your initials> Network Error Summary.
3. Click Add Data Source and select Backup > Backup Job Errors, then click Select Source.
4. Edit the Backup Job Errors Time Period to No Interval:
   a. Click on the Backup Job Errors data source.
   b. Expand the Time Period parameters and click Edit.
   c. In the Interval Type field, select No Interval from the drop-down.
   d. Click OK.
5. Modify the conditions of the data source:
   a. Expand the Condition property and click Edit Condition.
   b. Click Select Field and select Error and then click OK.
   c. Click Select Operator and select Contains and then click OK.
   d. Click Select Value, ensure that the Static Value Value Type radio button is selected, and type No such file or directory in the Value field. Then click OK.
   e. Click OK to close the window.

At this point the condition is set to return just backup jobs error details where the errors are no such file or directory.

6. Click Add Operator and select Math > Count and click Select Operator.
7. Connect Backup Job Errors to the Count operator.
8. Select the Count operator and expand the Fields property, and select Include All.
9. Click Add Operator and select Misc > Add Field and click Select Operator.
10. Connect Count to the Add Field operator.
11. Modify the parameters of the Add Field operator:
    a. Click on the Add Field operator and click Parameters to expand, and then click Edit.
    b. In the Cast field, select Text from the drop-down.
    c. In the Field Label field, type Reason.
    d. In the Value field, type No such file or directory.
    e. Click OK.

Field and value are the descriptions and text for the condition that you set in step 5.
12. Expand the **Fields** property and select **Include All**.

13. Click **Add Operator** and select **Misc > SetKey** and click **Select Operator**
   
The SetKey allows you to merge on common fields.

14. Connect Add Field operator to the SetKey operator.

15. Modify the parameters of the SetKey operator:
   
   a. Click on the SetKey operator and click **Parameters** to expand, and then click **Edit**.
   
   b. In the **Field Name** field, select **Reason** from the drop-down. Ensure that you select the **Key** checkbox.
   
   c. Click **OK**.

   This is required to set the keys properly for the correct report output.

16. Expand the **Fields** property and select **Include All**.

17. Use the cursor and the Ctrl key to select, copy, and paste all the objects except Report object.

   This is so you can create a second set of the same report data sources and operators to return another error type.

   Before you copy and paste the objects, move the Report object to the left of the existing objects to create extra space to the left. This is because DPA often copies objects to the left of the original objects.

   A shortcut for copying and pasting the objects is to use your cursor to select the objects starting outside of the objects, and then click the Copy and Paste icons on the toolbar at the top of the window.

   For example:
If after you copy and paste the objects are too small in the Design tab, use the Zoom to increase the percentage and increase the size of the objects within the Design tab. Alternatively, achieve this by holding down the cursor on the corner of the navigation pane and moving it in on the part of the report you want to zoom in on.

18. To rearrange the objects if necessary, click the Arrange icon in the toolbar.
19. Check that the time interval for the newly copied Backup Job Errors is set to No Interval.

20. Modify the newly copied and pasted Backup Job Errors condition value to retry attempted:
   a. Expand the Condition property and click Edit Condition.
   b. Click No such file or directory value, ensure that the Static Value Value Type radio button is selected, and type retry attempted in the Value field. Then click OK.

21. Modify the newly copied and pasted Add Field operator Field value to "Retry attempted:"
   a. Click on the Add Field operator and click Parameters to expand, and then click Edit.
   b. In the Value field, type Retry attempted.

You have added second set of operators and conditions to return a count of errors for retry attempted in the same report.

22. Click Add Operator and select Misc > Merge and click Select Operator

23. Connect both SetKey operators to the Merge operator.

24. Select the Merge operator and check that Include All is checked.

25. Connect the Merge operator to the Report object.

The report design should look like the following example:

26. Click the Preview tab.

27. Leave the default report format as Table.
    Table is the desired format for this report.

28. Select the scope for the report. Go to Select Scope > Configuration > Servers > [backup servers in your environment on which you would like to run the report].

29. Select the time period for the report. Go to Select Time Period.
Verify that the report returns two rows of data, each showing the count for the given error.

For example:

30. [Optional] Change the report appearance to Column Chart and run the report again. Click on Table from the Format drop-down, and select Column from the list.

For example:

31. Add the report to your Navigator menu.

Adding reports to menus on page 15 provides information.